En muchos casos cuando estamos usando PHP con la última versión de Apache, solamente la etiqueta <?php y <script> son reconocidos.  Un conjunto de los scripts están sin funcionar.  ¿Cómo puedo también habilitar la etiqueta <? ?

 Para esto es necesario editar el archivo de configuración de PHP llamado php.ini. Pero debemos tener en cuenta que el uso de etiquetas cortas se debe evitar en el desarrollo de aplicaciones o bibliotecas que esté destinados para su redistribución, o el desarrollo de PHP en servidores que no están bajo su control, porque las etiquetas cortas pueden no ser soportadas en el servidor de destino. Para uso portátil, redistribuciones de código, asegúrese de no utilizar etiquetas cortas.

Abrir php.ini ( /etc/php.ini o /usr/local/etc/php.ini), e ingresar:

# vi php.ini

Establecer short_open_tag a “On”:

short_open_tag = On

Guardar y cerrar el archivo. Reiniciar el servidor web:

# service httpd restart

O

# /usr/local/etc/rc.d/apache22 restart

(Visitado 396 veces, 1 visitas hoy)